Error Registering COM Object

Mar 13, 2013 at 10:48 PM
I am having a problem with the Error "Error Registering COM Object".

If I run the app through the development environment it is fine. If I deploy it to the webserver and run it on the localhost (http://LocalHost/AppName) it runs fine but if I put in the actual address (http://MySiteLocation/AppName) I get the error. The site is actually located on the development machine so all three options above are pointing to the same machine.

If you have any suggestions on what could be causing this, I would really appreciate it. Been trying to get an application together to access the client com ports for several days now.

Thanks in Advance.
Coordinator
Mar 14, 2013 at 8:26 AM
Hi Phixius,
thank you for your message.
First of all, I have to make sure I got it right.

Do you want to make an application for your client or are you trying to get access to the COM-ports of client machines connecting to http://MySiteLocation/AppName? This library only works in the first case. You have to install and run your app locally otherwise you will not be able to utilize the interopcom.
So if the latter is the case, maybe Silverlight 5 can be a bit of help?

Best regards,
Paul
Mar 14, 2013 at 3:33 PM
Hi Paul,
Thank you for the quick response and I guess I should have made my message a little more clear. I am using a SilverLight 5 app that I am hosting on a local IIS server. The app needs to open the COM port of the client machine so I am running it OOB as suggested. When I run it in the dev environment it works great. If I run it from the local host (http://LocalHost/AppName/) it works great but if I access it through the assigned link (http://MyLink/AppName/) I get the afore mentioned error. This is only my second attempt at a silverlight application so it could be something I am doing wrong on my side but I am sorta at a loss as to what that may be. Any suggestions to get this working would be very much appreciated. I have enough grey hair so don't need anymore.

Thanks in advance,
Phixius
Coordinator
Mar 21, 2013 at 10:28 PM
Hi Phixius,
sorry for the delayed answer. I still do not get what you try to accomplish. You can not access the local ports from a hosted app, though.
Silverlight 5 supports pinvoke without an lib like interopcom. So maybe you will be more successful with a direct approach. But I can not help you a lot, here, as I have not done any Silverlight lately.

Regards
Paul
Mar 22, 2013 at 12:14 AM
Hello Paul,
I apologize. I was actually able to trace down my issue. when I was declaring my object, it was not yet loaded so failed to initialize causing the error. Thank you.